VM detection in Docker

Hello,

Having deployed our Cryptlex-containing app in BitBucket pipes so as to perform DevOps on our project, we noticed that VM detection of these app instances running in docker containers doesn’t detect such a situation. Although we set a VM detection and forbidding in the license policy, Cryptlex doesn’t preclude the code from being executed in these docker containers. This seems special since we can’t reproduce the issue with our own docker images or VMs.

Cordially,

Hi,

Since Docker is not a virtual machine so AllowVm property doesn’t affect the application run in Docker.

Hi and thanks for your quick reply,

OK, we understand our local test was wrong since we were running docker inside a VM, Cryptlex blocking, and us thinking that AllowVm=false would block docker execution. Is there anyway we can prevent this or is the 200$/month floating server our only option to control the execution in docker images with your technology?

Cordially,

Hi Xavier,

We will see if we can add support for the same in node-locked/hosted-floating licenses too. Will keep you posted.

Thank you very much. At least, the hosted-floating license is clearly the most important for industrial (non connected) uses.

Hi,

Digging a bit further, I can’t find a way to offer my customers a trial period with a trial policy that prevents them from running the trial inside docker. Then they would simply rerun a docker of the trial app before the end of the trial and have a continuous use of the app for free. Or is there something, most probably, that we don’t understand correctly.

Thanks for your help,

Cordially,

Xavier

Hi Xavier,

We have added server side support for this. We will add the support in LexActivator in the next release, may take a week or two.

Wundershön!!!

Eagerly waiting for it, our launch depends on it!

Thank you!
Xavier

Hi Xavier,

We have added the required feature. Please use the latest version of the LexActivator.

In your policies/licenses you can set allowContainerActivation to false, through Web API.

Thank you so much Adnan

OK, trying this this morning, I can’t find the checkbox with “Allow Container Activation” when creating a Trial Policy. How do I create this policy? Thank you

You need to update the policy using the web API. The option is not exposed in the dashboard.