The product id is incorrect when LexActivator.ActivateTrial() is run

I am trying out the c# api and I keep getting LA_fail saying that the product id is incorrect, when I try to activate a trial or activate a product with a license key. I get the same error using the sample code. I have made sure that the productID and productdata are correct but still get the error.

It used to work, I used a different account and product before and switched over to test against my companys product today, when I suddenly got the issue. Any ideas?
LexActivator.IsTrialGenuine() returns LA-fail as well


If LexActivator.IsTrialGenuine() returns LA-fail it simply means the trial has not been activated on the machine. You need to call ActivateTrial() function to start the trial.

Yes but these lines alone returns invalid productID, I’ve checked many times now, made sure it sets correct productdata and ID, if I switch order of serProductdata and productID I get “invalid productdata”.

LexActivator.SetProductId(ProductId, LexActivator.PermissionFlags.LA_USER);

Thanks for the quick reply

I get it working whenever I use my own personal account, but when I set up an identical product at our company it fails. Do I need to set up something different on my end?

Also we run cryptlex on our own servers

Please refer to the following:

Hi thanks that’s what I’ve been lookign for. I can’t however find the SetCryptlexHost() in the lexactivator library. I’m using c#. What should I be referencing?

Please update to the v3.14.1.