Static library for libLexFloatClient


#1

Are there statically linkable .a libraries for the LexFloatClient on Linux distributions? I have seen other (older) forum posts that seem to indicate that they are available (or once were), but I don’t see them on the downloads page: https://app.cryptlex.com/downloads. I only see .so files.

Thanks!


#2

https://dl.cryptlex.com/downloads/v4.3.1/LexFloatClient-Static-Linux.zip

Here is the link to download the static library for LexFloatClient.


#3

Great! Thank you.

However, now I am seeing several “multiple definition of” linking errors when statically linking both libraries. I see from this post (Static linking of LexActivator and LexFloatClient) that someone may have ran into this issue before, albeit with different symbols.

Is it possible to resolve this conflict?

Thanks!


#4

Hi,

Both the libs can’t be linked statically. You can only link one lib statically at a time.