Segmentation Fault when linking with LexFloatClient

When I link statically or dynamically with LexFloat client, I am getting a segmentation fault in my normal code. I have not even invoked any Cryptlex API call, just the linking is causing my code to seg fault. If I remove it I am not seeing any issue.
Want to know if anyone has seen anything similar.


Which OS are you using? What is the LexFloatClient version? Can you replicate the issue with the samples available on Github:

I am on CentOs.
cat /etc/os-release
NAME=“CentOS Linux”
VERSION=“7 (Core)”
ID_LIKE=“rhel fedora”
PRETTY_NAME=“CentOS Linux 7 (Core)”

I tried a couple of examples on github and was not able to reproduce the issue. I am guessing it has something to do some other library my real application is linking to.

Can you share the list of libs your binary depends on?

ldd ./exe_bin => (0x00007ffe127ea000) => /lib64/ (0x00007f4307df7000) => /lib64/ (0x00007f4307b9e000) => /lib64/ (0x00007f430786f000) => /lib64/ (0x00007f4307631000) => /usr/lib/tbb/2019U8/cmake/…/lib/ (0x00007f43073f2000) => /usr/lib/tbb/2019U8/cmake/…/lib/ (0x00007f43071ee000) => /usr/lib/tbb/2019U8/cmake/…/lib/ (0x00007f4306fb1000) => /usr/lib/boost/1_71_0p/lib/ (0x00007f4306daf000) => /usr/lib/boost/1_71_0p/lib/ (0x00007f4306b85000) => /usr/lib/boost/1_71_0p/lib/ (0x00007f430696a000) => /usr/lib/glog/0.3.5/lib/ (0x00007f430673b000) => /usr/lib/gflags/2.2.2/lib/ (0x00007f430651a000) => /usr/lib/hdf5/1.10.4/lib/ (0x00007f43062f7000) => /usr/lib/hdf5/1.10.4/lib/ (0x00007f4305d26000) => /lib64/ (0x00007f4305b22000) => /usr/lib/lmdb/0.9.23/lib/ (0x00007f430590d000) => /usr/lib/opencv/ (0x00007f43054a1000) => /usr/lib/opencv/ (0x00007f4304fb2000) => /usr/lib/opencv/ (0x00007f4304b1a000) => /usr/lib/openblas/0.2.20/lib/ (0x00007f430451a000) => /usr/lib/python/3.7.5/lib/ (0x00007f4303fcf000) => /usr/lib/boost/1_71_0p/lib/ (0x00007f4303d93000) => /usr/lib/gcc/9.1.0/lib64/ (0x00007f43039ba000) => /lib64/ (0x00007f43036b8000) => /usr/lib/gcc/9.1.0/lib64/ (0x00007f43034a0000) => /lib64/ (0x00007f43030d2000)
/lib64/ (0x00007f4308013000) => /lib64/ (0x00007f4302ea2000) => /lib64/ (0x00007f4302c9d000) => /lib64/ (0x00007f4302a99000) => /lib64/ (0x00007f4302891000) => /usr/lib/hdf5/1.10.4/lib/ (0x00007f4302677000) => /lib64/ (0x00007f4302440000) => /lib64/ (0x00007f430223d000) => /lib64/ (0x00007f430203a000)

I can see you haven’t updated your makefile to remove the libnss dependency. Please refer to the following:

This may not be the cause of the issue, but you can see if it resolves the issue.

I removed these dependency but still get a seg-fault. I am using CMake to create the binary.
target_link_libraries(bin_name LexActivator pthread ssl3 )

Can you try linking dynamically? Or try running your binary using gdb.