Offline activation error

When some user send us a Request Code via email for offline activation, it sometimes fails with this error:

The JSON value could not be converted to System.Int32. Path: $.responseValidity | LineNumber: 0 | BytePositionInLine: 30.

I asked a user to paste the Request Code in a txt file and send me that file, thinking that there may be a formatting issue due to their/our email software. But the same error occured.

Any idea why this would happen?
I can send the license key and request code via email for you to check, if needed.


Do you paste the contents of the request file in the dashboard offline activation dialog or do you use REST API?

It was pasted in the dashboard.

Can you share the screenshot of the dialog after pressing the activate button?

When trying again today to take a screenshot, it worked!
It’s now working for all customers I had issues with.

I’m not sure if it’s a misuse on my part, or if something changed on your side.

Thanks for the quick replies :slight_smile:

Quick note for anyone having a similar issue in the future:

It continued to happen sporadically. Then I tried disabling a Chrome extension I use called Grammarly, and now it works fine.
This extension does spell-checking and other related things, it must be doing funky stuff in text fields, therefore corrupting the pasted activation codes.