How can I use LexActivator-Linux with PHP?

Hi everyone, I’m trying to work with LexActivator in CentOS 7.
I have added to PHP modules but it seems that it can’t be loaded.
Does anyone have worked with LexActivator in CentOS 7 before? Would you please guide me?
Thank you so much.


Lexactivator is a library, not a php module, to use it in php you would need to create a wrapper e.g.

What is the point of using Lexactivator with php as one doesn’t write desktop apps in php.

Dear support, thank you for your reply.
I’m trying to develop a JAR file.
When I call it in command line: java -jar abc.jar it can work well.
But when I call it by PHP ( shell_exec ), I got the message “Insufficent system permissions. Occurs when LA_SYSTEM flag is used but application is not run with admin privileges.”
I have tried with both LexActivator.LA_USER and LexActivator.LA_SYSTEM when set GUID.
Would you please help me in this case?

If your application doesn’t require admin privileges than you must use LA_USER flag. In that case you should not get the permission error.

In Linux the php script will be invoked by Apache and Apache is run using admin privileges. Try executing the script from terminal to verify.

Also ensure that shell exec is executing the java program with correct user

I see php Extention, I bumped! :slight_smile:

Well this was one of the pieces, I’ve been looking for my ending of PHP redis extension blog for update.
Looks like it is indeed one vast topic. Thanks for sharing, keep it live! :slight_smile:

Hi Wayne,

For PHP we recommend writing the licensing code in some other language (could be simple C) and then calling the C binary from your PHP code to validate the license key.