DllNotFoundException: Cryptlex.LexActivatorNative.SetProductData_x86(System.String)

Hello Support,

I am getting DDL not found error on one of the user’s systems (it’s a Microsoft Surface Pro 3 (64bit OS with Windows 10 Pro)). Below DDL’s shipped with the application installer -

  • Cryptlex.LexActivator.dll
  • LexActivator.dll
  • LexActivator32.dll

I tried by adding vsx86 dlls (msvcp100 and msvcr100) but that did not work. Can you help which DLL it’s looking for.

Just to again let you know, it’s just an issue on this system and it’s working all fine on other systems.

Below is the full error -

Description: The process was terminated due to an unhandled exception.
Exception Info: System.DllNotFoundException
   at Cryptlex.LexActivatorNative.SetProductData_x86(System.String)
   at Cryptlex.LexActivator.SetProductData(System.String)



As per the docs LexActivator has dependency on the VS2015 (or above) runtime.

But why we are only getting this error on that particular system? I don’t think I have ever faced this on any other system.

It means the runtime wasn’t already installed on the machine, which usually is.

That is strange because we are never shipping or asking to download it on any system and I doubt that not all users would have it installed on their system.

It is by default installed on Windows 10, I suppose your customer may have uninstalled it.

Still getting the same error and the app is not launching.

I guess the customer hasn’t installed the 32 bit runtime, as you seem to be running 32 bit app on 64 bit machine.

That worked!! Thanks.